You do need a webkit engine

Because of technologies we are implementing to be able to access this database you do need a webkit browser (or a tablet device). You may click one of the icons below to install a compatible browser:

Google Chrome Safari Opera